Help Portal

Twitch is always live—except for when it's not.

See which areas of Twitch are thriving or having a bit of a rough day below.

Need assistance?


Contact us with any questions or concerns, or follow @TwitchSupport for updates

Identified Video (Broadcasting) Issues
Incident Report for Twitch
Resolved
🛠 We've resolved all known issues of broadcasters not being able to stream on Twitch.
Posted Aug 24, 2022 - 23:17 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 24, 2022 - 23:06 UTC
Identified
🛠 We have identified an issue preventing people from broadcasting on Twitch. We're currently working to resolve this issue.
Posted Aug 24, 2022 - 21:34 UTC
This incident affected: Video (Broadcasting).