Help Portal

Twitch is always live—except for when it's not.

See which areas of Twitch are thriving or having a bit of a rough day below.

Need assistance?


Contact us with any questions or concerns, or follow @TwitchSupport for updates

Identified Mobile Issues
Incident Report for Twitch
Resolved
This incident has been resolved.
Posted Nov 29, 2022 - 01:03 UTC
Investigating
🛠 We have identified an issue affecting mobile users. We're currently working to resolve this issue.
Posted Nov 28, 2022 - 22:44 UTC