Help Portal

Twitch is always live—except for when it's not.

See which areas of Twitch are thriving or having a bit of a rough day below.

Need assistance?


Contact us with any questions or concerns, or follow @TwitchSupport for updates

Identified Checkout Issues
Incident Report for Twitch
Resolved
🛠 We have resolved all known issues causing people to be unable to make purchases.
Posted Mar 23, 2021 - 02:33 UTC
Investigating
🛠 We have identified an issue causing some users to be unable to checkout. We're currently working to resolve this issue.
Posted Mar 23, 2021 - 01:32 UTC
This incident affected: Purchases.