Help Portal

Twitch is always live—except for when it's not.

See which areas of Twitch are thriving or having a bit of a rough day below.

Need assistance?


Contact us with any questions or concerns, or follow @TwitchSupport for updates

Identified Purchases Issues
Incident Report for Twitch
Resolved
This incident has been resolved.
Posted Feb 02, 2022 - 08:02 UTC
Identified
🛠 We have identified an issue causing some users to be unable to make purchases. We're currently working to resolve this issue.
Posted Feb 02, 2022 - 07:14 UTC
This incident affected: Purchases.