Help Portal

Twitch is always live—except for when it's not.

See which areas of Twitch are thriving or having a bit of a rough day below.

Need assistance?


Contact us with any questions or concerns, or follow @TwitchSupport for updates

Video (VOD) Issues - Identified
Incident Report for Twitch
Resolved
This incident has been resolved.
Posted Nov 03, 2022 - 23:39 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 03, 2022 - 20:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2022 - 20:58 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 03, 2022 - 20:44 UTC
Investigating
🛠 We have identified an issue preventing people from watching Vods on Twitch. We're currently working to resolve this issue.
Posted Nov 03, 2022 - 20:23 UTC
This incident affected: Video (Watching).